Out-of-bounds Read Affecting tar-rmt package, versions <1.34-150000.3.12.1


Severity

Recommended
medium

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.1% (66th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES153-TARRMT-2808904
  • published6 May 2022
  • disclosed5 May 2022

Introduced: 5 May 2022

CVE-2021-20193  (opens in a new tab)
CWE-125  (opens in a new tab)
CWE-401  (opens in a new tab)

How to fix?

Upgrade SLES:15.3 tar-rmt to version 1.34-150000.3.12.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream tar-rmt package and not the tar-rmt package as distributed by SLES. See How to fix? for SLES:15.3 relevant fixed versions and status.

A flaw was found in the src/list.c of tar 1.33 and earlier. This flaw allows an attacker who can submit a crafted input file to tar to cause uncontrolled consumption of memory. The highest threat from this vulnerability is to system availability.

CVSS Base Scores

version 3.1