Out-of-bounds Read Affecting transfig package, versions <3.2.8b-4.15.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.89% (56th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES153-TRANSFIG-2659196
  • published14 Apr 2022
  • disclosed29 Oct 2021

Introduced: 29 Oct 2021

CVE-2020-21535  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade SLES:15.3 transfig to version 3.2.8b-4.15.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream transfig package and not the transfig package as distributed by SLES. See How to fix? for SLES:15.3 relevant fixed versions and status.

fig2dev 3.2.7b contains a segmentation fault in the gencgm_start function in gencgm.c.

CVSS Base Scores

version 3.1