CVE-2021-33516 Affecting typelib-1_0-GUPnP-1_0 package, versions <1.2.2-3.3.1


Severity

Recommended
0.0
critical
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.08% (61st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES153-TYPELIB10GUPNP10-2672484
  • published14 Apr 2022
  • disclosed24 Jun 2021

Introduced: 24 Jun 2021

CVE-2021-33516  (opens in a new tab)

How to fix?

Upgrade SLES:15.3 typelib-1_0-GUPnP-1_0 to version 1.2.2-3.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream typelib-1_0-GUPnP-1_0 package and not the typelib-1_0-GUPnP-1_0 package as distributed by SLES. See How to fix? for SLES:15.3 relevant fixed versions and status.

An issue was discovered in GUPnP before 1.0.7 and 1.1.x and 1.2.x before 1.2.5. It allows DNS rebinding. A remote web server can exploit this vulnerability to trick a victim's browser into triggering actions against local UPnP services implemented using this library. Depending on the affected service, this could be used for data exfiltration, data tempering, etc.

CVSS Base Scores

version 3.1