Improper Input Validation Affecting udisks2 package, versions <2.8.1-150200.3.3.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.91% (59th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES153-UDISKS2-3018712
  • published8 Sept 2022
  • disclosed7 Sept 2022

Introduced: 7 Sep 2022

CVE-2021-3802  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade SLES:15.3 udisks2 to version 2.8.1-150200.3.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream udisks2 package and not the udisks2 package as distributed by SLES. See How to fix? for SLES:15.3 relevant fixed versions and status.

A vulnerability found in udisks2. This flaw allows an attacker to input a specially crafted image file/USB leading to kernel panic. The highest threat from this vulnerability is to system availability.

CVSS Base Scores

version 3.1