CVE-2025-48976 Affecting apache-commons-fileupload package, versions <1.6.0-150200.3.12.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
32.88% (99th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES154-APACHECOMMONSFILEUPLOAD-10559624
  • published28 Jun 2025
  • disclosed27 Jun 2025

Introduced: 27 Jun 2025

CVE-2025-48976  (opens in a new tab)

How to fix?

Upgrade SLES:15.4 apache-commons-fileupload to version 1.6.0-150200.3.12.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream apache-commons-fileupload package and not the apache-commons-fileupload package as distributed by SLES. See How to fix? for SLES:15.4 relevant fixed versions and status.

Allocation of resources for multipart headers with insufficient limits enabled a DoS vulnerability in Apache Commons FileUpload.

This issue affects Apache Commons FileUpload: from 1.0 before 1.6; from 2.0.0-M1 before 2.0.0-M4.

Users are recommended to upgrade to versions 1.6 or 2.0.0-M4, which fix the issue.

CVSS Base Scores

version 3.1