CVE-2025-6547 Affecting aws-cli package, versions <1.33.26-150400.34.7.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.46% (38th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES154-AWSCLI-13706842
  • published24 Oct 2025
  • disclosed23 Oct 2025

Introduced: 23 Oct 2025

CVE-2025-6547  (opens in a new tab)

How to fix?

Upgrade SLES:15.4 aws-cli to version 1.33.26-150400.34.7.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream aws-cli package and not the aws-cli package as distributed by SLES. See How to fix? for SLES:15.4 relevant fixed versions and status.

Improper Input Validation vulnerability in pbkdf2 allows Signature Spoofing by Improper Validation.This issue affects pbkdf2: <=3.1.2.

CVSS Base Scores

version 3.1