Insufficient Verification of Data Authenticity Affecting aws-iam-authenticator package, versions <0.7.18-150000.1.17.1


Severity

Recommended
0.0
low
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.05% (60th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES154-AWSIAMAUTHENTICATOR-17614884
  • published27 Jun 2026
  • disclosed26 Jun 2026

Introduced: 26 Jun 2026

CVE-2024-39689  (opens in a new tab)
CWE-345  (opens in a new tab)

How to fix?

Upgrade SLES:15.4 aws-iam-authenticator to version 0.7.18-150000.1.17.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream aws-iam-authenticator package and not the aws-iam-authenticator package as distributed by SLES. See How to fix? for SLES:15.4 relevant fixed versions and status.

Certifi is a curated collection of Root Certificates for validating the trustworthiness of SSL certificates while verifying the identity of TLS hosts. Certifi starting in 2021.5.30 and prior to 2024.7.4 recognized root certificates from GLOBALTRUST. Certifi 2024.7.04 removes root certificates from GLOBALTRUST from the root store. These are in the process of being removed from Mozilla's trust store. GLOBALTRUST's root certificates are being removed pursuant to an investigation which identified "long-running and unresolved compliance issues."

CVSS Base Scores

version 3.1