CVE-2022-2385 Affecting aws-iam-authenticator package, versions <0.7.18-150000.1.17.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.1% (65th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES154-AWSIAMAUTHENTICATOR-17614997
  • published27 Jun 2026
  • disclosed26 Jun 2026

Introduced: 26 Jun 2026

CVE-2022-2385  (opens in a new tab)

How to fix?

Upgrade SLES:15.4 aws-iam-authenticator to version 0.7.18-150000.1.17.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream aws-iam-authenticator package and not the aws-iam-authenticator package as distributed by SLES. See How to fix? for SLES:15.4 relevant fixed versions and status.

A security issue was discovered in aws-iam-authenticator where an allow-listed IAM identity may be able to modify their username and escalate privileges.

CVSS Base Scores

version 3.1