Incorrect Default Permissions Affecting buildah package, versions <1.25.1-150400.3.3.28


0.0
medium

Snyk CVSS

    Attack Complexity Low
Expand this section
SUSE
5.9 medium
Expand this section
RHEL
4.8 medium
Expand this section
NVD
6.8 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-SLES154-BUILDAH-2976169
  • published 6 Aug 2022
  • disclosed 5 Aug 2022

How to fix?

Upgrade SLES:15.4 buildah to version 1.25.1-150400.3.3.28 or higher.

NVD Description

Note: Versions mentioned in the description apply to the upstream buildah package. See How to fix? for SLES:15.4 relevant versions.

A flaw was found in buildah where containers were incorrectly started with non-empty default permissions. A bug was found in Moby (Docker Engine) where containers were incorrectly started with non-empty inheritable Linux process capabilities, enabling an attacker with access to programs with inheritable file capabilities to elevate those capabilities to the permitted set when execve(2) runs. This has the potential to impact confidentiality and integrity.