CVE-2026-89528 Affecting dlm-kmp-default package, versions <5.14.21-150400.24.246.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.65% (51st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES154-DLMKMPDEFAULT-21876466
  • published30 Oct 2026
  • disclosed29 Oct 2026

Introduced: 29 Oct 2026

NewCVE-2026-89528  (opens in a new tab)

How to fix?

Upgrade SLES:15.4 dlm-kmp-default to version 5.14.21-150400.24.246.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream dlm-kmp-default package and not the dlm-kmp-default package as distributed by SLES. See How to fix? for SLES:15.4 relevant fixed versions and status.

In the Linux kernel, the following vulnerability has been resolved:

svcrdma: Reject Read lists that exceed the page budget

Individual Read segment lengths are validated at decode time, but nothing prevents a requester from sending multiple segments whose cumulative length exceeds the rq_pages array budget. When one segment fills the page array exactly, the runtime guard in svc_rdma_build_read_segment() is bypassed because len reaches zero. A subsequent segment then accesses the NULL sentinel slot at rq_pages[rq_maxpages], resulting in a NULL pointer dereference during DMA mapping.

Accumulate pages across all Read segments and reject the message at decode time when the total would overflow the page budget.

CVSS Base Scores

version 3.1