CVE-2026-99999 Affecting dlm-kmp-default package, versions <5.14.21-150400.24.246.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
0.79% (56th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES154-DLMKMPDEFAULT-21877676
  • published30 Oct 2026
  • disclosed29 Oct 2026

Introduced: 29 Oct 2026

NewCVE-2026-99999  (opens in a new tab)

How to fix?

Upgrade SLES:15.4 dlm-kmp-default to version 5.14.21-150400.24.246.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream dlm-kmp-default package and not the dlm-kmp-default package as distributed by SLES. See How to fix? for SLES:15.4 relevant fixed versions and status.

In the Linux kernel, the following vulnerability has been resolved:

ipv4: validate checksum_start before completing checksum

If a packet with bad checksum metadata gets into the ipv4 stack, skb_checksum_help can corrupt the network header and cause a bunch of mischief.

This was discovered and reported by Paulos, and has been reporoduced by others independently since.

We really shouldn't allow such packets in, but as a defence in depth measure, let's also check before we complete the checksum.

A more complete validation at input is forthcoming, but needs more work.

CVSS Base Scores

version 3.1