Integer Overflow or Wraparound Affecting gdk-pixbuf-query-loaders package, versions <2.42.8-150400.5.3.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.8% (55th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES154-GDKPIXBUFQUERYLOADERS-3016822
  • published3 Sept 2022
  • disclosed2 Sept 2022

Introduced: 2 Sep 2022

CVE-2021-46829  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade SLES:15.4 gdk-pixbuf-query-loaders to version 2.42.8-150400.5.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gdk-pixbuf-query-loaders package and not the gdk-pixbuf-query-loaders package as distributed by SLES. See How to fix? for SLES:15.4 relevant fixed versions and status.

GNOME GdkPixbuf (aka GDK-PixBuf) before 2.42.8 allows a heap-based buffer overflow when compositing or clearing frames in GIF files, as demonstrated by io-gif-animation.c composite_frame. This overflow is controllable and could be abused for code execution, especially on 32-bit systems.

CVSS Base Scores

version 3.1