Buffer Overflow Affecting gdk-pixbuf-thumbnailer package, versions <2.42.12-150400.5.14.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.34% (71st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES154-GDKPIXBUFTHUMBNAILER-12179335
  • published25 Aug 2025
  • disclosed22 Aug 2025

Introduced: 22 Aug 2025

CVE-2025-7345  (opens in a new tab)
CWE-120  (opens in a new tab)

How to fix?

Upgrade SLES:15.4 gdk-pixbuf-thumbnailer to version 2.42.12-150400.5.14.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gdk-pixbuf-thumbnailer package and not the gdk-pixbuf-thumbnailer package as distributed by SLES. See How to fix? for SLES:15.4 relevant fixed versions and status.

A flaw exists in gdk‑pixbuf within the gdk_pixbuf__jpeg_image_load_increment function (io-jpeg.c) and in glib’s g_base64_encode_step (glib/gbase64.c). When processing maliciously crafted JPEG images, a heap buffer overflow can occur during Base64 encoding, allowing out-of-bounds reads from heap memory, potentially causing application crashes or arbitrary code execution.

CVSS Base Scores

version 3.1