Out-of-bounds Write Affecting gdk-pixbuf-thumbnailer package, versions <2.42.9-150400.5.6.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.91% (79th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES154-GDKPIXBUFTHUMBNAILER-3018722
  • published8 Sept 2022
  • disclosed7 Sept 2022

Introduced: 7 Sep 2022

CVE-2021-44648  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade SLES:15.4 gdk-pixbuf-thumbnailer to version 2.42.9-150400.5.6.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gdk-pixbuf-thumbnailer package and not the gdk-pixbuf-thumbnailer package as distributed by SLES. See How to fix? for SLES:15.4 relevant fixed versions and status.

GNOME gdk-pixbuf 2.42.6 is vulnerable to a heap-buffer overflow vulnerability when decoding the lzw compressed stream of image data in GIF files with lzw minimum code size equals to 12.

CVSS Base Scores

version 3.1