CVE-2025-43023 Affecting hplip-udev-rules package, versions <3.26.4-150400.3.22.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.27% (18th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES154-HPLIPUDEVRULES-17333532
  • published13 Jun 2026
  • disclosed11 Jun 2026

Introduced: 11 Jun 2026

CVE-2025-43023  (opens in a new tab)

How to fix?

Upgrade SLES:15.4 hplip-udev-rules to version 3.26.4-150400.3.22.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream hplip-udev-rules package and not the hplip-udev-rules package as distributed by SLES. See How to fix? for SLES:15.4 relevant fixed versions and status.

A potential security vulnerability has been identified in the HP Linux Imaging and Printing Software documentation. This potential vulnerability is due to the use of a weak code signing key, Digital Signature Algorithm (DSA).

CVSS Base Scores

version 3.1