Heap-based Buffer Overflow Affecting ImageMagick package, versions <7.1.0.9-150400.6.18.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.59% (44th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES154-IMAGEMAGICK-5441576
  • published21 Apr 2023
  • disclosed20 Apr 2023

Introduced: 20 Apr 2023

CVE-2023-1906  (opens in a new tab)
CWE-122  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade SLES:15.4 ImageMagick to version 7.1.0.9-150400.6.18.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ImageMagick package and not the ImageMagick package as distributed by SLES. See How to fix? for SLES:15.4 relevant fixed versions and status.

A heap-based buffer overflow issue was discovered in ImageMagick's ImportMultiSpectralQuantum() function in MagickCore/quantum-import.c. An attacker could pass specially crafted file to convert, triggering an out-of-bounds read error, allowing an application to crash, resulting in a denial of service.

CVSS Base Scores

version 3.1