Directory Traversal Affecting kubevirt-virtctl package, versions <0.54.0-150400.3.3.2


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.38% (32nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES154-KUBEVIRTVIRTCTL-3031743
  • published23 Sept 2022
  • disclosed22 Sept 2022

Introduced: 22 Sep 2022

CVE-2022-1798  (opens in a new tab)
CWE-22  (opens in a new tab)

How to fix?

Upgrade SLES:15.4 kubevirt-virtctl to version 0.54.0-150400.3.3.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream kubevirt-virtctl package and not the kubevirt-virtctl package as distributed by SLES. See How to fix? for SLES:15.4 relevant fixed versions and status.

A path traversal vulnerability in KubeVirt versions up to 0.56 (and 0.55.1) on all platforms allows a user able to configure the kubevirt to read arbitrary files on the host filesystem which are publicly readable or which are readable for UID 107 or GID 107. /proc/self/<> is not accessible.

CVSS Base Scores

version 3.1