Integer Overflow or Wraparound Affecting libasan4 package, versions <7.5.0+r278197-150000.4.49.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.44% (39th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES154-LIBASAN4-21751049
  • published27 Oct 2026
  • disclosed26 Oct 2026

Introduced: 26 Oct 2026

NewCVE-2026-95619  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade SLES:15.4 libasan4 to version 7.5.0+r278197-150000.4.49.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libasan4 package and not the libasan4 package as distributed by SLES. See How to fix? for SLES:15.4 relevant fixed versions and status.

A flaw was found in libstdc++. An integer overflow can occur when processing large inputs to the aligned operator new in the C++ library. This vulnerability could lead to an undersized memory allocation, potentially causing memory corruption or application instability.

CVSS Base Scores

version 3.1