Use After Free Affecting libavif16 package, versions <1.3.0-150400.3.6.1


Severity

Recommended
critical

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.92% (60th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES154-LIBAVIF16-12818318
  • published17 Sept 2025
  • disclosed16 Sept 2025

Introduced: 16 Sep 2025

CVE-2023-6351  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade SLES:15.4 libavif16 to version 1.3.0-150400.3.6.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libavif16 package and not the libavif16 package as distributed by SLES. See How to fix? for SLES:15.4 relevant fixed versions and status.

Use after free in libavif in Google Chrome prior to 119.0.6045.199 allowed a remote attacker to potentially exploit heap corruption via a crafted avif file. (Chromium security severity: High)

CVSS Base Scores

version 3.1