CVE-2023-27349 Affecting libbluetooth3 package, versions <5.62-150400.4.13.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.43% (70th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES154-LIBBLUETOOTH3-5735879
  • published24 Jun 2023
  • disclosed22 Jun 2023

Introduced: 22 Jun 2023

CVE-2023-27349  (opens in a new tab)

How to fix?

Upgrade SLES:15.4 libbluetooth3 to version 5.62-150400.4.13.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libbluetooth3 package and not the libbluetooth3 package as distributed by SLES. See How to fix? for SLES:15.4 relevant fixed versions and status.

BlueZ Audio Profile AVRCP Improper Validation of Array Index Remote Code Execution Vulnerability. This vulnerability allows network-adjacent attackers to execute arbitrary code via Bluetooth on affected installations of BlueZ. User interaction is required to exploit this vulnerability in that the target must connect to a malicious device.

The specific flaw exists within the handling of the AVRCP protocol. The issue results from the lack of proper validation of user-supplied data, which can result in a write past the end of an allocated buffer. An attacker can leverage this vulnerability to execute code in the context of root. Was ZDI-CAN-19908.

CVSS Base Scores

version 3.1