Memory Leak Affecting libcap2 package, versions <2.63-150400.3.3.1


Severity

Recommended
0.0
low
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.35% (29th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES154-LIBCAP2-5752418
  • published4 Jul 2023
  • disclosed3 Jul 2023

Introduced: 3 Jul 2023

CVE-2023-2602  (opens in a new tab)
CWE-401  (opens in a new tab)

How to fix?

Upgrade SLES:15.4 libcap2 to version 2.63-150400.3.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libcap2 package and not the libcap2 package as distributed by SLES. See How to fix? for SLES:15.4 relevant fixed versions and status.

A vulnerability was found in the pthread_create() function in libcap. This issue may allow a malicious actor to use cause __real_pthread_create() to return an error, which can exhaust the process memory.

CVSS Base Scores

version 3.1