Expired Pointer Dereference Affecting libcilkrts5 package, versions <7.5.0+r278197-150000.4.49.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.34% (28th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES154-LIBCILKRTS5-21750944
  • published27 Oct 2026
  • disclosed26 Oct 2026

Introduced: 26 Oct 2026

NewCVE-2026-102010  (opens in a new tab)
CWE-825  (opens in a new tab)

How to fix?

Upgrade SLES:15.4 libcilkrts5 to version 7.5.0+r278197-150000.4.49.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libcilkrts5 package and not the libcilkrts5 package as distributed by SLES. See How to fix? for SLES:15.4 relevant fixed versions and status.

A flaw was found in GCC. When an application calls the erase_if function on a binary heap priority queue in libstdc++, the library reallocates storage but fails to update its internal entry pointer. An attacker capable of triggering this operation can exploit this use-after-free condition, leading to a Denial of Service (DoS) via an application crash or potential memory corruption.

CVSS Base Scores

version 3.1