CVE-2023-50980 Affecting libcryptopp-devel package, versions <8.6.0-150400.3.3.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.83% (53rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES154-LIBCRYPTOPPDEVEL-6144793
  • published5 Jan 2024
  • disclosed4 Jan 2024

Introduced: 4 Jan 2024

CVE-2023-50980  (opens in a new tab)

How to fix?

Upgrade SLES:15.4 libcryptopp-devel to version 8.6.0-150400.3.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libcryptopp-devel package and not the libcryptopp-devel package as distributed by SLES. See How to fix? for SLES:15.4 relevant fixed versions and status.

gf2n.cpp in Crypto++ (aka cryptopp) through 8.9.0 allows attackers to cause a denial of service (application crash) via DER public-key data for an F(2^m) curve, if the degree of each term in the polynomial is not strictly decreasing.

CVSS Base Scores

version 3.1