CVE-2023-34969 Affecting libdbus-1-3 package, versions <1.12.2-150400.18.8.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.51% (74th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES154-LIBDBUS13-5789936
  • published20 Jul 2023
  • disclosed19 Jul 2023

Introduced: 19 Jul 2023

CVE-2023-34969  (opens in a new tab)

How to fix?

Upgrade SLES:15.4 libdbus-1-3 to version 1.12.2-150400.18.8.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libdbus-1-3 package and not the libdbus-1-3 package as distributed by SLES. See How to fix? for SLES:15.4 relevant fixed versions and status.

D-Bus before 1.15.6 sometimes allows unprivileged users to crash dbus-daemon. If a privileged user with control over the dbus-daemon is using the org.freedesktop.DBus.Monitoring interface to monitor message bus traffic, then an unprivileged user with the ability to connect to the same dbus-daemon can cause a dbus-daemon crash under some circumstances via an unreplyable message. When done on the well-known system bus, this is a denial-of-service vulnerability. The fixed versions are 1.12.28, 1.14.8, and 1.15.6.

CVSS Base Scores

version 3.1