Buffer Overflow Affecting libheif1 package, versions <1.12.0-150400.3.8.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.31% (23rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES154-LIBHEIF1-5414942
  • published6 Apr 2023
  • disclosed5 Apr 2023

Introduced: 5 Apr 2023

CVE-2023-0996  (opens in a new tab)
CWE-120  (opens in a new tab)

How to fix?

Upgrade SLES:15.4 libheif1 to version 1.12.0-150400.3.8.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libheif1 package and not the libheif1 package as distributed by SLES. See How to fix? for SLES:15.4 relevant fixed versions and status.

There is a vulnerability in the strided image data parsing code in the emscripten wrapper for libheif. An attacker could exploit this through a crafted image file to cause a buffer overflow in linear memory during a memcpy call.

CVSS Base Scores

version 3.1