Buffer Overflow Affecting libicu-devel package, versions <65.1-150200.4.15.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.44% (38th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES154-LIBICUDEVEL-10500144
  • published25 Jun 2025
  • disclosed24 Jun 2025

Introduced: 24 Jun 2025

CVE-2025-5222  (opens in a new tab)
CWE-120  (opens in a new tab)

How to fix?

Upgrade SLES:15.4 libicu-devel to version 65.1-150200.4.15.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libicu-devel package and not the libicu-devel package as distributed by SLES. See How to fix? for SLES:15.4 relevant fixed versions and status.

A stack buffer overflow was found in Internationl components for unicode (ICU ). While running the genrb binary, the 'subtag' struct overflowed at the SRBRoot::addTag function. This issue may lead to memory corruption and local arbitrary code execution.

CVSS Base Scores

version 3.1