Integer Overflow or Wraparound Affecting libiperf0 package, versions <3.15-150000.3.6.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.96% (79th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES154-LIBIPERF0-5925635
  • published29 Sept 2023
  • disclosed28 Sept 2023

Introduced: 28 Sep 2023

CVE-2023-38403  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade SLES:15.4 libiperf0 to version 3.15-150000.3.6.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libiperf0 package and not the libiperf0 package as distributed by SLES. See How to fix? for SLES:15.4 relevant fixed versions and status.

iperf3 before 3.14 allows peers to cause an integer overflow and heap corruption via a crafted length field.

CVSS Base Scores

version 3.1