CVE-2024-53427 Affecting libjq1 package, versions <1.7.1-150000.3.25.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.36% (31st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES154-LIBJQ1-20044007
  • published22 Sept 2026
  • disclosed21 Sept 2026

Introduced: 21 Sep 2026

CVE-2024-53427  (opens in a new tab)

How to fix?

Upgrade SLES:15.4 libjq1 to version 1.7.1-150000.3.25.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libjq1 package and not the libjq1 package as distributed by SLES. See How to fix? for SLES:15.4 relevant fixed versions and status.

decNumberCopy in decNumber.c in jq through 1.7.1 does not properly consider that NaN is interpreted as numeric, which has a resultant stack-based buffer overflow and out-of-bounds write, as demonstrated by use of --slurp with subtraction, such as a filter of .-. when the input has a certain form of digit string with NaN (e.g., "1 NaN123" immediately followed by many more digits).

CVSS Base Scores

version 3.1