CVE-2026-54679 Affecting libjq-devel package, versions <1.7.1-150000.3.25.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.15% (4th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES154-LIBJQDEVEL-20044141
  • published22 Sept 2026
  • disclosed21 Sept 2026

Introduced: 21 Sep 2026

CVE-2026-54679  (opens in a new tab)

How to fix?

Upgrade SLES:15.4 libjq-devel to version 1.7.1-150000.3.25.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libjq-devel package and not the libjq-devel package as distributed by SLES. See How to fix? for SLES:15.4 relevant fixed versions and status.

jq is a command-line JSON processor. Prior to 1.8.2, on 32bit system, jvp_string_append has a chance of integer/multiple overflowing and then causing a massive buffer overrun. This vulnerability is fixed in 1.8.2.

CVSS Base Scores

version 3.1