Memory Leak Affecting liblasso3 package, versions <2.6.1-150200.24.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.64% (49th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES154-LIBLASSO3-13976927
  • published14 Nov 2025
  • disclosed13 Nov 2025

Introduced: 13 Nov 2025

CVE-2025-46784  (opens in a new tab)
CWE-401  (opens in a new tab)

How to fix?

Upgrade SLES:15.4 liblasso3 to version 2.6.1-150200.24.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream liblasso3 package and not the liblasso3 package as distributed by SLES. See How to fix? for SLES:15.4 relevant fixed versions and status.

A denial of service vulnerability exists in the lasso_node_init_from_message_with_format functionality of Entr&#39;ouvert Lasso 2.5.1. A specially crafted SAML response can lead to a memory depletion, resulting in denial of service. An attacker can send a malformed SAML response to trigger this vulnerability.

CVSS Base Scores

version 3.1