Buffer Overflow Affecting liblouis20 package, versions <3.20.0-150400.3.3.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.45% (73rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES154-LIBLOUIS20-2944497
  • published7 Jul 2022
  • disclosed6 Jul 2022

Introduced: 6 Jul 2022

CVE-2022-26981  (opens in a new tab)
CWE-120  (opens in a new tab)

How to fix?

Upgrade SLES:15.4 liblouis20 to version 3.20.0-150400.3.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream liblouis20 package and not the liblouis20 package as distributed by SLES. See How to fix? for SLES:15.4 relevant fixed versions and status.

Liblouis through 3.21.0 has a buffer overflow in compilePassOpcode in compileTranslationTable.c (called, indirectly, by tools/lou_checktable.c).

CVSS Base Scores

version 3.1