Buffer Overflow Affecting liblouis-devel package, versions <3.20.0-150400.3.8.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.16% (65th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES154-LIBLOUISDEVEL-5414910
  • published6 Apr 2023
  • disclosed5 Apr 2023

Introduced: 5 Apr 2023

CVE-2023-26769  (opens in a new tab)
CWE-120  (opens in a new tab)

How to fix?

Upgrade SLES:15.4 liblouis-devel to version 3.20.0-150400.3.8.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream liblouis-devel package and not the liblouis-devel package as distributed by SLES. See How to fix? for SLES:15.4 relevant fixed versions and status.

Buffer Overflow vulnerability found in Liblouis Lou_Trace v.3.24.0 allows a remote attacker to cause a denial of service via the resolveSubtable function at compileTranslationTabel.c.

CVSS Base Scores

version 3.1