Use After Free Affecting libMagick++-devel package, versions <7.1.0.9-150400.6.27.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.48% (40th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES154-LIBMAGICKDEVEL-5961113
  • published12 Oct 2023
  • disclosed11 Oct 2023

Introduced: 11 Oct 2023

CVE-2023-5341  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade SLES:15.4 libMagick++-devel to version 7.1.0.9-150400.6.27.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libMagick++-devel package and not the libMagick++-devel package as distributed by SLES. See How to fix? for SLES:15.4 relevant fixed versions and status.

A heap use-after-free flaw was found in coders/bmp.c in ImageMagick.

CVSS Base Scores

version 3.1