CVE-2024-29166 Affecting libmca_common_dstore1 package, versions <3.2.3-150300.3.10.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.21% (12th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES154-LIBMCACOMMONDSTORE1-7376530
  • published26 Jun 2024
  • disclosed25 Jun 2024

Introduced: 25 Jun 2024

CVE-2024-29166  (opens in a new tab)

How to fix?

Upgrade SLES:15.4 libmca_common_dstore1 to version 3.2.3-150300.3.10.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libmca_common_dstore1 package and not the libmca_common_dstore1 package as distributed by SLES. See How to fix? for SLES:15.4 relevant fixed versions and status.

HDF5 through 1.14.3 contains a buffer overflow in H5O__linfo_decode, resulting in the corruption of the instruction pointer and causing denial of service or potential code execution.

CVSS Base Scores

version 3.1