OS Command Injection Affecting libnm0 package, versions <1.32.12-150400.3.6.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.17% (6th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES154-LIBNM0-19856261
  • published16 Sept 2026
  • disclosed14 Sept 2026

Introduced: 14 Sep 2026

CVE-2026-10805  (opens in a new tab)
CWE-78  (opens in a new tab)

How to fix?

Upgrade SLES:15.4 libnm0 to version 1.32.12-150400.3.6.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libnm0 package and not the libnm0 package as distributed by SLES. See How to fix? for SLES:15.4 relevant fixed versions and status.

A flaw was found in NetworkManager. This local privilege escalation vulnerability exists in NetworkManager's dhclient backend when processing malformed Manufacturer Usage Description (MUD) URLs. A local user can exploit this flaw to escalate privileges by triggering a script via a crafted MUD URL, provided an administrator has explicitly configured NetworkManager to use dhclient. This issue does not affect default configurations of NetworkManager.

CVSS Base Scores

version 3.1