Double Free Affecting libpmi0_22_05 package, versions <22.05.11-150300.7.9.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.38% (72nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES154-LIBPMI02205-6221844
  • published1 Feb 2024
  • disclosed31 Jan 2024

Introduced: 31 Jan 2024

CVE-2023-49937  (opens in a new tab)
CWE-415  (opens in a new tab)

How to fix?

Upgrade SLES:15.4 libpmi0_22_05 to version 22.05.11-150300.7.9.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libpmi0_22_05 package and not the libpmi0_22_05 package as distributed by SLES. See How to fix? for SLES:15.4 relevant fixed versions and status.

An issue was discovered in SchedMD Slurm 22.05.x, 23.02.x, and 23.11.x. Because of a double free, attackers can cause a denial of service or possibly execute arbitrary code. The fixed versions are 22.05.11, 23.02.7, and 23.11.1.

CVSS Base Scores

version 3.1