Insufficiently Protected Credentials Affecting librabbitmq4 package, versions <0.10.0-150300.5.6.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.22% (13th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES154-LIBRABBITMQ4-6369043
  • published3 Mar 2024
  • disclosed14 Jul 2023

Introduced: 14 Jul 2023

CVE-2023-35789  (opens in a new tab)
CWE-522  (opens in a new tab)

How to fix?

Upgrade SLES:15.4 librabbitmq4 to version 0.10.0-150300.5.6.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream librabbitmq4 package and not the librabbitmq4 package as distributed by SLES. See How to fix? for SLES:15.4 relevant fixed versions and status.

An issue was discovered in the C AMQP client library (aka rabbitmq-c) through 0.13.0 for RabbitMQ. Credentials can only be entered on the command line (e.g., for amqp-publish or amqp-consume) and are thus visible to local attackers by listing a process and its arguments.

CVSS Base Scores

version 3.1