Buffer Overflow Affecting libraw16 package, versions <0.18.9-150000.3.23.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.77% (53rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES154-LIBRAW16-5932552
  • published5 Oct 2023
  • disclosed4 Oct 2023

Introduced: 4 Oct 2023

CVE-2020-22628  (opens in a new tab)
CWE-120  (opens in a new tab)

How to fix?

Upgrade SLES:15.4 libraw16 to version 0.18.9-150000.3.23.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libraw16 package and not the libraw16 package as distributed by SLES. See How to fix? for SLES:15.4 relevant fixed versions and status.

Buffer Overflow vulnerability in LibRaw::stretch() function in libraw\src\postprocessing\aspect_ratio.cpp.

CVSS Base Scores

version 3.1