Integer Overflow or Wraparound Affecting libraw20 package, versions <0.20.2-150400.3.21.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.57% (45th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES154-LIBRAW20-16191386
  • published24 Apr 2026
  • disclosed22 Apr 2026

Introduced: 22 Apr 2026

CVE-2026-20884  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade SLES:15.4 libraw20 to version 0.20.2-150400.3.21.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libraw20 package and not the libraw20 package as distributed by SLES. See How to fix? for SLES:15.4 relevant fixed versions and status.

An integer overflow vulnerability exists in the deflate_dng_load_raw functionality of LibRaw Commit 8dc68e2. A specially crafted malicious file can lead to a heap buffer overflow. An attacker can provide a malicious file to trigger this vulnerability.

CVSS Base Scores

version 3.1