Buffer Overflow Affecting libraw-devel package, versions <0.20.2-150400.3.9.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.77% (53rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES154-LIBRAWDEVEL-5932430
  • published5 Oct 2023
  • disclosed4 Oct 2023

Introduced: 4 Oct 2023

CVE-2020-22628  (opens in a new tab)
CWE-120  (opens in a new tab)

How to fix?

Upgrade SLES:15.4 libraw-devel to version 0.20.2-150400.3.9.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libraw-devel package and not the libraw-devel package as distributed by SLES. See How to fix? for SLES:15.4 relevant fixed versions and status.

Buffer Overflow vulnerability in LibRaw::stretch() function in libraw\src\postprocessing\aspect_ratio.cpp.

CVSS Base Scores

version 3.1