Out-of-bounds Read Affecting libsqlite3-0 package, versions <3.53.2-150000.3.42.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.2% (10th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES154-LIBSQLITE30-17437933
  • published24 Jun 2026
  • disclosed23 Jun 2026

Introduced: 23 Jun 2026

CVE-2026-11822  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade SLES:15.4 libsqlite3-0 to version 3.53.2-150000.3.42.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libsqlite3-0 package and not the libsqlite3-0 package as distributed by SLES. See How to fix? for SLES:15.4 relevant fixed versions and status.

SQLite before 3.53.2 contains an out-of-bounds read vulnerability in the FTS5 full-text search extension that allows attackers to crash the process by supplying a crafted database with a malformed FTS5 leaf page. Attackers can set an oversized term length in the leaf page so that fts5LeafSeek() reads past the end of the page buffer while comparing terms during an FTS5 MATCH query, in applications compiled with SQLITE_ENABLE_FTS5.

CVSS Base Scores

version 3.1