Memory Leak Affecting libvirt-daemon-driver-nodedev package, versions <8.0.0-150400.7.6.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.25% (17th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES154-LIBVIRTDAEMONDRIVERNODEDEV-5664996
  • published3 Jun 2023
  • disclosed2 Jun 2023

Introduced: 2 Jun 2023

CVE-2023-2700  (opens in a new tab)
CWE-401  (opens in a new tab)

How to fix?

Upgrade SLES:15.4 libvirt-daemon-driver-nodedev to version 8.0.0-150400.7.6.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libvirt-daemon-driver-nodedev package and not the libvirt-daemon-driver-nodedev package as distributed by SLES. See How to fix? for SLES:15.4 relevant fixed versions and status.

A vulnerability was found in libvirt. This security flaw ouccers due to repeatedly querying an SR-IOV PCI device's capabilities that exposes a memory leak caused by a failure to free the virPCIVirtualFunction array within the parent struct's g_autoptr cleanup.

CVSS Base Scores

version 3.1