Access of Resource Using Incompatible Type ('Type Confusion') Affecting libxslt1 package, versions <1.1.34-150400.3.13.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.28% (21st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES154-LIBXSLT1-15344228
  • published25 Feb 2026
  • disclosed24 Feb 2026

Introduced: 24 Feb 2026

CVE-2025-11731  (opens in a new tab)
CWE-843  (opens in a new tab)

How to fix?

Upgrade SLES:15.4 libxslt1 to version 1.1.34-150400.3.13.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libxslt1 package and not the libxslt1 package as distributed by SLES. See How to fix? for SLES:15.4 relevant fixed versions and status.

A flaw was found in the exsltFuncResultComp() function of libxslt, which handles EXSLT <func:result> elements during stylesheet parsing. Due to improper type handling, the function may treat an XML document node as a regular XML element node, resulting in a type confusion. This can cause unexpected memory reads and potential crashes. While difficult to exploit, the flaw could lead to application instability or denial of service.

CVSS Base Scores

version 3.1