Improper Input Validation Affecting luajit package, versions <2.1.0~beta3+git.1624618403.e9577376-150400.4.2.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
4.58% (91st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES154-LUAJIT-5752452
  • published4 Jul 2023
  • disclosed6 Dec 2023

Introduced: 4 Jul 2023

CVE-2016-7069  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade SLES:15.4 luajit to version 2.1.0~beta3+git.1624618403.e9577376-150400.4.2.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream luajit package and not the luajit package as distributed by SLES. See How to fix? for SLES:15.4 relevant fixed versions and status.

An issue has been found in dnsdist before 1.2.0 in the way EDNS0 OPT records are handled when parsing responses from a backend. When dnsdist is configured to add EDNS Client Subnet to a query, the response may contain an EDNS0 OPT record that has to be removed before forwarding the response to the initial client. On a 32-bit system, the pointer arithmetic used when parsing the received response to remove that record might trigger an undefined behavior leading to a crash.