CVE-2024-22365 Affecting pam-devel package, versions <1.3.0-150000.6.66.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.46% (37th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES154-PAMDEVEL-6179929
  • published19 Jan 2024
  • disclosed18 Jan 2024

Introduced: 18 Jan 2024

CVE-2024-22365  (opens in a new tab)

How to fix?

Upgrade SLES:15.4 pam-devel to version 1.3.0-150000.6.66.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pam-devel package and not the pam-devel package as distributed by SLES. See How to fix? for SLES:15.4 relevant fixed versions and status.

linux-pam (aka Linux PAM) before 1.6.0 allows attackers to cause a denial of service (blocked login process) via mkfifo because the openat call (for protect_dir) lacks O_DIRECTORY.

CVSS Base Scores

version 3.1