CVE-2026-2474 Affecting perl-Crypt-URandom package, versions <0.550.0-150000.1.6.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.35% (27th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES154-PERLCRYPTURANDOM-16756334
  • published19 May 2026
  • disclosed18 May 2026

Introduced: 18 May 2026

CVE-2026-2474  (opens in a new tab)

How to fix?

Upgrade SLES:15.4 perl-Crypt-URandom to version 0.550.0-150000.1.6.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream perl-Crypt-URandom package and not the perl-Crypt-URandom package as distributed by SLES. See How to fix? for SLES:15.4 relevant fixed versions and status.

Crypt::URandom versions from 0.41 before 0.55 for Perl is vulnerable to a heap buffer overflow in the XS function crypt_urandom_getrandom().

The function does not validate that the length parameter is non-negative. If a negative value (e.g. -1) is supplied, the expression length + 1u causes an integer wraparound, resulting in a zero-byte allocation. The subsequent call to getrandom(data, length, GRND_NONBLOCK) passes the original negative value, which is implicitly converted to a large unsigned value (typically SIZE_MAX). This can result in writes beyond the allocated buffer, leading to heap memory corruption and application crash (denial of service).

In common usage, the length argument is typically hardcoded by the caller, which reduces the likelihood of attacker-controlled exploitation. Applications that pass untrusted input to this parameter may be affected.

CVSS Base Scores

version 3.1