Out-of-bounds Write Affecting perl-PerlMagick package, versions <7.1.0.9-150400.6.9.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.49% (42nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES154-PERLPERLMAGICK-3038546
  • published2 Oct 2022
  • disclosed1 Oct 2022

Introduced: 1 Oct 2022

CVE-2022-3213  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade SLES:15.4 perl-PerlMagick to version 7.1.0.9-150400.6.9.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream perl-PerlMagick package and not the perl-PerlMagick package as distributed by SLES. See How to fix? for SLES:15.4 relevant fixed versions and status.

A heap buffer overflow issue was found in ImageMagick. When an application processes a malformed TIFF file, it could lead to undefined behavior or a crash causing a denial of service.

CVSS Base Scores

version 3.1