Link Following Affecting php8-pecl package, versions <1.10.21-150400.9.3.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
73.38% (100th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES154-PHP8PECL-3019848
  • published9 Sept 2022
  • disclosed8 Sept 2022

Introduced: 8 Sep 2022

CVE-2021-32610  (opens in a new tab)
CWE-59  (opens in a new tab)

How to fix?

Upgrade SLES:15.4 php8-pecl to version 1.10.21-150400.9.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream php8-pecl package and not the php8-pecl package as distributed by SLES. See How to fix? for SLES:15.4 relevant fixed versions and status.

In Archive_Tar before 1.4.14, symlinks can refer to targets outside of the extracted archive, a different vulnerability than CVE-2020-36193.

CVSS Base Scores

version 3.1