Race Condition Affecting pmix-plugins package, versions <3.2.3-150300.3.8.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.23% (68th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES154-PMIXPLUGINS-5925796
  • published29 Sept 2023
  • disclosed28 Sept 2023

Introduced: 28 Sep 2023

CVE-2023-41915  (opens in a new tab)
CWE-362  (opens in a new tab)

How to fix?

Upgrade SLES:15.4 pmix-plugins to version 3.2.3-150300.3.8.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pmix-plugins package and not the pmix-plugins package as distributed by SLES. See How to fix? for SLES:15.4 relevant fixed versions and status.

OpenPMIx PMIx before 4.2.6 and 5.0.x before 5.0.1 allows attackers to obtain ownership of arbitrary files via a race condition during execution of library code with UID 0.

CVSS Base Scores

version 3.1