CVE-2021-22904 Affecting ruby2.5-rubygem-actionpack-5_1 package, versions <5.1.4-150000.3.12.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
4.87% (92nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES154-RUBY25RUBYGEMACTIONPACK51-2929032
  • published17 Jun 2022
  • disclosed16 Jun 2022

Introduced: 16 Jun 2022

CVE-2021-22904  (opens in a new tab)

How to fix?

Upgrade SLES:15.4 ruby2.5-rubygem-actionpack-5_1 to version 5.1.4-150000.3.12.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby2.5-rubygem-actionpack-5_1 package and not the ruby2.5-rubygem-actionpack-5_1 package as distributed by SLES. See How to fix? for SLES:15.4 relevant fixed versions and status.

The actionpack ruby gem before 6.1.3.2, 6.0.3.7, 5.2.4.6, 5.2.6 suffers from a possible denial of service vulnerability in the Token Authentication logic in Action Controller due to a too permissive regular expression. Impacted code uses authenticate_or_request_with_http_token or authenticate_with_http_token for request authentication.

CVSS Base Scores

version 3.1